Nice article.

I personally disagree with "Helpers"

That name is meaningless and is avoiding the responsibility of finding a good name.

It is a code smell of a missing responsibility somewhere.

I agree with you that repeated code is another code smell. The solution, IMHO is to find a REAL object in the REAL world with that responsibility. And I Have never seen a Helper in the real world.

That's just an opinion.

https://codeburst.io/the-one-and-only-software-design-principle-5328420712af

Written by

I’m senior software engineer specialized in declarative designs. S.O.L.I.D. and agile methodologies fan.

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store